Jump to content

Installation Error


Recommended Posts

I have attempted to install JAM on an Ubuntu 14.04 server. I have PHP 5.5 with Curl (Short tags are enabled), MYSQL 5.5.47-0. I have ioncube installed [echo var_export(extension_loaded('ionCube Loader') ,true); >>> true]. I'm currently running Nginx as a reverse proxy for apache2.


Apache2 conf

 



# The ServerName directive sets the request scheme, hostname and port that

# the server uses to identify itself. This is used when creating

# redirection URLs. In the context of virtual hosts, the ServerName

# specifies what hostname must appear in the request's Host: header to

# match this virtual host. For the default virtual host (this file) this

# value is not decisive as it is used as a last resort host regardless.

# However, you must set it for any further virtual host explicitly.

#ServerName www.example.com


ServerAdmin webmaster@localhost

DocumentRoot /var/www/html


# Available loglevels: trace8, ..., trace1, debug, info, notice, warn,

# error, crit, alert, emerg.

# It is also possible to configure the loglevel for particular

# modules, e.g.

#LogLevel info ssl:warn


ErrorLog ${APACHE_LOG_DIR}/error.log

CustomLog ${APACHE_LOG_DIR}/access.log combined


# For most configuration files from conf-available/, which are

# enabled or disabled at a global level, it is possible to

# include a line for only one particular virtual host. For example the

# following line enables the CGI configuration for this host only

# after it has been globally disabled with "a2disconf".

#Include conf-available/serve-cgi-bin.conf


 



Nginx conf

 


server {

listen 80;


root /var/www/;

index index.php index.html index.htm;


server_name aff.thebiblicalherbal.com;


location / {

try_files $uri $uri/ /index.php;

}


location ~ \.php$ {


proxy_set_header X-Real-IP $remote_addr;

proxy_set_header X-Forwarded-For $remote_addr;

proxy_set_header Host $host;

proxy_pass http://127.0.0.1:8080;


}


location ~ /\.ht {

deny all;

}

}


 



I can access "affiliates/install/index.php", complete step 1, but once I finish step 2 it give a 500 error. No logs are being generated at "system/logs".

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...