Jump to content
Otheriz

New Install Admin Login Redirect to itself

Recommended Posts

Dear Admin,

I'm new user for this system, currently i finish the installation..
but when i try to login to the /admin_login it redirect back to the login page..

i now try it on the localhost:81 environment

please advice

Share this post


Link to post
Share on other sites

It's working, But i still looking for a way to be available on the localhost environment

because it's hard to develop, since i still use hosting for our system..i need to develop it on the localhost first(like another system)..


But so far this system is one of candidate(seems promising) that i will use in the production website..

Share this post


Link to post
Share on other sites

you can still install it on localhost, you can just setup a test domain name and add it to your hosts file on your PC.

Share this post


Link to post
Share on other sites

I have try several setting but still not working..

is this a correct setting...i use xampp at my local device..
setting at file "httpd-vhosts.conf"

<VirtualHost *:81>
    ServerAdmin admin@affiliates.com
    DocumentRoot "C:/xampp/htdocs/affiliates"
    ServerName affiliates.localhost
    ServerAlias www.affiliates.localhost
    ErrorLog "logs/affiliates.localhost-error.log"
    CustomLog "logs/affiliates.localhost-access.log" common
</VirtualHost>

 

"config.php"

$config['base_license_domain_name'] = 'localhost:81';
$config['base_physical_path'] = 'C:\xampp\htdocs\affiliates';
$config['base_folder_path'] = '';
$config['base_domain_name'] = 'localhost:81';
$config['base_subdomain_name'] = 'affiliates';
........
$config['sess_cookie_name']			= 'jrox_session7035';
$config['sess_expiration']			= 60 * 60 * 24 * 7;
$config['sess_expiration_pub']		= 60 * 60 * 24 * 7;
$config['sess_encrypt_cookie']		= FALSE;
$config['sess_use_database']			= TRUE;
$config['sess_table_name']			= 'sessions';
$config['sess_match_ip']				= FALSE;
$config['sess_match_useragent']		= FALSE;
$config['sess_time_to_update'] 		= 300;

 Please Advice...

Share this post


Link to post
Share on other sites

i see this setting also on the bottom line of "config.php"...i don't know if this related or not

$config['permitted_uri_chars'] = '@+=\a-z 0-9~%.:_-';

 

Share this post


Link to post
Share on other sites

you need to set a temporary domain in your hosts file, something like:

127.0.0.1  www.testdomain.com

 

Then install it using that domain.  You need a valid domain so that session cookies are properly set for authentication when you login to administer the app.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...